using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"JOIN:0x[a-zA-Z0-9]{16},OK";
string input = @"JOIN:2,ERR
JOIN:0x000b57fffe00e8c6,OK";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}