package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`JOIN:0x[a-zA-Z0-9]{16},OK`)
var str = `JOIN:2,ERR
JOIN:0x000b57fffe00e8c6,OK`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}