// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"JOIN:0x[a-zA-Z0-9]{16},OK").unwrap();
let string = "JOIN:2,ERR
JOIN:0x000b57fffe00e8c6,OK";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}