const regex = new RegExp('^%.*|\\\\THISTAG[^{]+{([^}]+)}', 'gm')
const str = `maybe there is some text \\THISTAG[arg1=1,argtwo]{WANT0}
% \\THISTAG[arg1=1,argtwo]{NOTWANT}
% blah blah \\THISTAG[arg1=1,argtwo]{NOTWANT}
\\THISTAG[arg1=1,argtwo]{WANT1}\\THISTAG[arg1=1,argtwo]{WANT2}\\\\stuff
\\sometag{stuff I don't want}[{\\THISTAG[arg1=1,argtwo]{WANT3}}]{more stuff I don't want}
\\THISTAG[arg1=1,argtwo]{OBV_WANT}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}