$re = '/^%.*|\\\\THISTAG[^{]+{([^}]+)}/m';
$str = 'maybe there is some text \\THISTAG[arg1=1,argtwo]{WANT0}
% \\THISTAG[arg1=1,argtwo]{NOTWANT}
% blah blah \\THISTAG[arg1=1,argtwo]{NOTWANT}
\\THISTAG[arg1=1,argtwo]{WANT1}\\THISTAG[arg1=1,argtwo]{WANT2}\\\\stuff
\\sometag{stuff I don\'t want}[{\\THISTAG[arg1=1,argtwo]{WANT3}}]{more stuff I don\'t want}
\\THISTAG[arg1=1,argtwo]{OBV_WANT}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);