import re
regex = re.compile(r"^%.*|\\THISTAG[^{]+{([^}]+)}", flags=re.MULTILINE)
test_str = ("maybe there is some text \\THISTAG[arg1=1,argtwo]{WANT0}\n"
"% \\THISTAG[arg1=1,argtwo]{NOTWANT}\n"
"% blah blah \\THISTAG[arg1=1,argtwo]{NOTWANT}\n"
"\\THISTAG[arg1=1,argtwo]{WANT1}\\THISTAG[arg1=1,argtwo]{WANT2}\\\\stuff\n"
"\\sometag{stuff I don't want}[{\\THISTAG[arg1=1,argtwo]{WANT3}}]{more stuff I don't want}\n"
"\\THISTAG[arg1=1,argtwo]{OBV_WANT}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")