#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<div\s[\s\S]*?featurebullets_feature_div[\s\S]*?>\s*<div\s[\s\S]*?feature-bullets[\s\S]*?>\s*(<ul[\s\S]*?<\/ul>)[\s\S]*?<\/div>[\s\S]*?<\/div>"
Local $sString = "<div id="featurebullets_feature_div" class="feature" data-feature-name="featurebullets" data-cel-widget="featurebullets_feature_div">" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div id="feature-bullets" class="a-section a-spacing-medium a-spacing-top-small">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <ul class="a-unordered-list a-vertical a-spacing-none">" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" 100% Washed Twill" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" Imported" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" Rubber sole" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" Shaft measures approximately Low-Top" from arch" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" Heel measures approximately 0.75"" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" Platform measures approximately 0.5"" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" <li><span class="a-list-item"> " & @CRLF & _
" Slip-on canvas sneaker featuring laceless vamp and small logo tags at tongue and topline" & @CRLF & _
" " & @CRLF & _
" </span></li>" & @CRLF & _
" " & @CRLF & _
" </ul>" & @CRLF & _
" <!-- Loading EDP related metadata -->" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<span class="edp-feature-declaration" data-edp-feature-name="featurebullets" data-edp-asin="B00NNA39IE" data-data-hash="3757568849" data-defects="[{"id":"defect-mismatch-info","value":"Different from product"},{"id":"defect-missing-information","value":"Missing information"},{"id":"defect-unessential-info","value":"Unimportant information"},{"id":"defect-other-productinfo-issue","value":"Other"}]" data-metadata="CATALOG" data-feature-container-id="" data-custom-event-handler="" data-display-name="Bullet Points" data-edit-data-state="featureBulletsEDPEditData" data-position="" data-resolver="CQResolver"></span>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")