import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\s[\\s\\S]*?featurebullets_feature_div[\\s\\S]*?>\\s*<div\\s[\\s\\S]*?feature-bullets[\\s\\S]*?>\\s*(<ul[\\s\\S]*?<\\/ul>)[\\s\\S]*?<\\/div>[\\s\\S]*?<\\/div>";
final String string = "<div id=\"featurebullets_feature_div\" class=\"feature\" data-feature-name=\"featurebullets\" data-cel-widget=\"featurebullets_feature_div\">\n"
+ " \n"
+ " \n\n\n\n\n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n\n\n"
+ "<div id=\"feature-bullets\" class=\"a-section a-spacing-medium a-spacing-top-small\">\n\n\n\n\n\n\n\n\n"
+ " \n"
+ " \n"
+ " <ul class=\"a-unordered-list a-vertical a-spacing-none\">\n"
+ " \n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " 100% Washed Twill\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " Imported\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " Rubber sole\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " Shaft measures approximately Low-Top\" from arch\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " Heel measures approximately 0.75\"\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " Platform measures approximately 0.5\"\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " <li><span class=\"a-list-item\"> \n"
+ " Slip-on canvas sneaker featuring laceless vamp and small logo tags at tongue and topline\n"
+ " \n"
+ " </span></li>\n"
+ " \n"
+ " </ul>\n"
+ " <!-- Loading EDP related metadata -->\n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n\n\n\n\n"
+ "<span class=\"edp-feature-declaration\" data-edp-feature-name=\"featurebullets\" data-edp-asin=\"B00NNA39IE\" data-data-hash=\"3757568849\" data-defects=\"[{"id":"defect-mismatch-info","value":"Different from product"},{"id":"defect-missing-information","value":"Missing information"},{"id":"defect-unessential-info","value":"Unimportant information"},{"id":"defect-other-productinfo-issue","value":"Other"}]\" data-metadata=\"CATALOG\" data-feature-container-id=\"\" data-custom-event-handler=\"\" data-display-name=\"Bullet Points\" data-edit-data-state=\"featureBulletsEDPEditData\" data-position=\"\" data-resolver=\"CQResolver\"></span>\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n\n"
+ " \n\n"
+ " \n"
+ "</div>\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}