use strict;
my $str = '<div id="featurebullets_feature_div" class="feature" data-feature-name="featurebullets" data-cel-widget="featurebullets_feature_div">
<div id="feature-bullets" class="a-section a-spacing-medium a-spacing-top-small">
<ul class="a-unordered-list a-vertical a-spacing-none">
<li><span class="a-list-item">
100% Washed Twill
</span></li>
<li><span class="a-list-item">
Imported
</span></li>
<li><span class="a-list-item">
Rubber sole
</span></li>
<li><span class="a-list-item">
Shaft measures approximately Low-Top" from arch
</span></li>
<li><span class="a-list-item">
Heel measures approximately 0.75"
</span></li>
<li><span class="a-list-item">
Platform measures approximately 0.5"
</span></li>
<li><span class="a-list-item">
Slip-on canvas sneaker featuring laceless vamp and small logo tags at tongue and topline
</span></li>
</ul>
<!-- Loading EDP related metadata -->
<span class="edp-feature-declaration" data-edp-feature-name="featurebullets" data-edp-asin="B00NNA39IE" data-data-hash="3757568849" data-defects="[{"id":"defect-mismatch-info","value":"Different from product"},{"id":"defect-missing-information","value":"Missing information"},{"id":"defect-unessential-info","value":"Unimportant information"},{"id":"defect-other-productinfo-issue","value":"Other"}]" data-metadata="CATALOG" data-feature-container-id="" data-custom-event-handler="" data-display-name="Bullet Points" data-edit-data-state="featureBulletsEDPEditData" data-position="" data-resolver="CQResolver"></span>
</div>
</div>';
my $regex = qr/<div\s[\s\S]*?featurebullets_feature_div[\s\S]*?>\s*<div\s[\s\S]*?feature-bullets[\s\S]*?>\s*(<ul[\s\S]*?<\/ul>)[\s\S]*?<\/div>[\s\S]*?<\/div>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}