#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\w\-\.]+txt:route-policy\sGERENCIA_UBB_STATIC.+"
Local $sString = "RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP" & @CRLF & _
"RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP" & @CRLF & _
"RMAGRJO-MTC01-01.txt- if tag eq 30210 then" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")