using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)?bitbucket\.org\/(?<author>[\w-]+)\/(?<repo>[\w-]+)\/?(src\/)?(?<branch>[\w-]+)?";
string input = @"https://bitbucket.org/cloudrepo-examples/maven-library-example/src/master/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}