re = /(https?:\/\/)?bitbucket\.org\/(?<author>[\w-]+)\/(?<repo>[\w-]+)\/?(src\/)?(?<branch>[\w-]+)?/m
str = 'https://bitbucket.org/cloudrepo-examples/maven-library-example/src/master/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end