package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/)?bitbucket\.org\/(?<author>[\w-]+)\/(?<repo>[\w-]+)\/?(src\/)?(?<branch>[\w-]+)?`)
var str = `https://bitbucket.org/cloudrepo-examples/maven-library-example/src/master/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}