$re = '/(<)([a-zA-Z0-9:.]+)(?:(?: ((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)(?: |>))(?:(?:((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)?(?: |>))?(?:(?:((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)?(?: |>))?/';
$str = '<div attr="Something" data-attr="test" data-foo> adsfasd asdfasd fasdf
<div attr="Something" data-attr="test">
<div attr="Something">
<a href=""/>
<div attr="Something"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);