re = /(<)([a-zA-Z0-9:.]+)(?:(?: ((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)(?: |>))(?:(?:((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)?(?: |>))?(?:(?:((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)?(?: |>))?/
str = '<div attr="Something" data-attr="test" data-foo> adsfasd asdfasd fasdf
<div attr="Something" data-attr="test">
<div attr="Something">
<a href=""/>
<div attr="Something"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end