import re
regex = re.compile(r"(<)([a-zA-Z0-9:.]+)(?:(?: ((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)(?: |>))(?:(?:((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)?(?: |>))?(?:(?:((?<= )[^ ]+?(?==| |>)))(?:=[^ >]+)?(?: |>))?")
test_str = ("<div attr=\"Something\" data-attr=\"test\" data-foo> adsfasd asdfasd fasdf\n"
"<div attr=\"Something\" data-attr=\"test\">\n"
"<div attr=\"Something\">\n"
"<a href=\"\"/>\n"
"<div attr=\"Something\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")