import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:https?):\\/\\/)?(?:\\S+(?::\\S*)?@)?(?:(?:[a-z0-9][a-z0-9\\-]*?[a-z0-9]+)(?:\\.(?:[a-z0-9\\-])*[a-z0-9]+)*(?:\\.(?:[a-z]{2,})(:\\d{1,5})?))(?:\\/[^\\s]*)?)(?:[ ]+[^< ]|\\Z|\\n)";
final String string = "jkNKLJNLKJASSDNBVKLJAVD http://www.google.com\n"
+ " http://www.google.com\n"
+ "<a href=\"http://www.w3schools.com\">Visit W3Schools.com!</a>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}