import Foundation
// WARNING: You included a flag that Swift doesn't support: J
// Wehn this flag is set, it allows duplicated capturing group names.
// By default, Swift captures only the last value matched for a repeated capture group.
// As an alternative, the pattern can be modified to contain one capturing group per group you want to get in the result.
let pattern = #"""
(?<=^|\v)
\h*+\*\h*+
(?:
(?:
(?P<annotation>
@(?P<name>\w++)
(?:
(?<=@param)\h++(?P<type>\w++(?:\[\])?)\h++\$(?P<variable>\w++)
|(?<=@return)\h++(?P<type>\w++(?:\[\])?)
|(?<=@throws)\h++(?P<class>\w++)
|(?<=@cache)\h++(?P<time>\d++)
|(?<=@roles)\h++(?P<roles>\w++(?:\h*+,\h*+\w++)*)
)?
)
)
(?P<comment>\h++[^\v]++)?
(?:(?P<comment>\v)\h*+\*\h*+(?P<comment>[^\v@\h\*][^\v]++))*+
|(?P<description>(?:[^\v@\h\*][^\v]++)
(?:
\v\h*+\*\h*+[^\v@\h\*][^\v]++
)*+
)
)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
/**
* bla bla
*bla2 @ bla2 @
*
* bla bla 3
*
* @olivier voila
* @param string $sku1 bidule
*
* @param string[] $sku2
*
* @param string $sku3 toto bidule @
* machin truc
*
* @param string $sku4
* machin truc
*
* @deprecated
*
* @deprecated toto
*
* @throws Exception
* @throws Exception
* machin
* @return Cfe_Type_Product
* @cache 3600
* @roles toto, titi,truc , machin
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)