use strict;
my $str = '9/91 x1 cx.papaya 94000
9/92 x2 mango 10220
9/93 x3 pineapple
9/94 x4 cx.apple 94000
9/95 x5 cx.orange
19/192 x7 cx.fruit 1235';
my $regex = qr/^(\d+\/\d+\hx\d+)\h(?:\w+\.)?(\w+)\h?(\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}