$re = '/^(\d+\/\d+\hx\d+)\h(?:\w+\.)?(\w+)\h?(\d+)?$/m';
$str = '9/91 x1 cx.papaya 94000
9/92 x2 mango 10220
9/93 x3 pineapple
9/94 x4 cx.apple 94000
9/95 x5 cx.orange
19/192 x7 cx.fruit 1235';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);