# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d+\/\d+\hx\d+)\h(?:\w+\.)?(\w+)\h?(\d+)?$"
test_str = ("9/91 x1 cx.papaya 94000\n"
"9/92 x2 mango 10220\n"
"9/93 x3 pineapple\n"
"9/94 x4 cx.apple 94000\n"
"9/95 x5 cx.orange\n"
"19/192 x7 cx.fruit 1235")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.