using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bfull name \| \b(.*)\bdate of birth \| \b(.*)\bplace of birth \| \b(.*)\bdate of death \| \b(.*)\bplace of death \| \b(.*)";
string substitution = @"";
string input = @"full name | Nguy\:1ec5n Sinh Cung date of birth | Monday, May 19, 1890 (125 years ago) place of birth | Vietnam date of death | Tuesday, September 2, 1969 (age: 79 years) (46 years ago) place of death | Hanoi, Red River Delta
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}