// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bfull name \| \b(.*)\bdate of birth \| \b(.*)\bplace of birth \| \b(.*)\bdate of death \| \b(.*)\bplace of death \| \b(.*)").unwrap();
let string = "full name | Nguy\\:1ec5n Sinh Cung date of birth | Monday, May 19, 1890 (125 years ago) place of birth | Vietnam date of death | Tuesday, September 2, 1969 (age: 79 years) (46 years ago) place of death | Hanoi, Red River Delta
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}