import re
regex = re.compile(r"\bfull name \| \b(.*)\bdate of birth \| \b(.*)\bplace of birth \| \b(.*)\bdate of death \| \b(.*)\bplace of death \| \b(.*)")
test_str = ("full name | Nguy\\:1ec5n Sinh Cung date of birth | Monday, May 19, 1890 (125 years ago) place of birth | Vietnam date of death | Tuesday, September 2, 1969 (age: 79 years) (46 years ago) place of death | Hanoi, Red River Delta\n")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)