package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`c(?<start>\d+(?:\[\d+])?)(?:-(?<end>(?&start)?))?`)
var str = `c2,c3-5,c6[2],c8[4]-10,c14-21[5]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}