// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"c(?<start>\d+(?:\[\d+])?)(?:-(?<end>(?&start)?))?").unwrap();
let string = "c2,c3-5,c6[2],c8[4]-10,c14-21[5]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}