$re = '/c(?<start>\d+(?:\[\d+])?)(?:-(?<end>(?&start)?))?/';
$str = 'c2,c3-5,c6[2],c8[4]-10,c14-21[5]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);