package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@.+?º`)
var str = `@8~Cº + @9~Cº
@11~Cº + @12~P1º - @13~Fº`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}