const regex = /@.+?º/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@.+?º', 'gm')
const str = `@8~Cº + @9~Cº
@11~Cº + @12~P1º - @13~Fº`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}