$re = '/@.+?º/m';
$str = '@8~Cº + @9~Cº
@11~Cº + @12~P1º - @13~Fº';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);