package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\w\.]\.net\b`)
var str = `.net Full-Stack Developer (Angular, .net Core, SQL) .network zaicev.net .net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}