re = /[^\w\.]\.net\b/m
str = '.net Full-Stack Developer (Angular, .net Core, SQL) .network zaicev.net .net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end