$re = '/[^\w\.]\.net\b/m';
$str = '.net Full-Stack Developer (Angular, .net Core, SQL) .network zaicev.net .net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);