import re
regex = re.compile(r"(?:\babcdef)(?:.*\n)*(?:\bfedcba)", flags=re.MULTILINE)
test_str = ("patata\n"
"abcdef\n"
"Aliquam erat volutpat. Proin ultrices\n"
"Testing\n\n"
"test[](test)\n"
"Testing\n"
"fedcba\n"
"Testing\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")