package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\b((?:public|protected|private)\s+)|((?:abstract|static)\s+)|(final\s+)|((?:volatile|synchronized)\s+)|((?:native|strictfp)\s+))+`)
var str = ` static public void main(String[] args)`
var substitution = "$1$2$3$4$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}