const regex = /(?:\b((?:public|protected|private)\s+)|((?:abstract|static)\s+)|(final\s+)|((?:volatile|synchronized)\s+)|((?:native|strictfp)\s+))+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b((?:public|protected|private)\\s+)|((?:abstract|static)\\s+)|(final\\s+)|((?:volatile|synchronized)\\s+)|((?:native|strictfp)\\s+))+', 'gm')
const str = ` static public void main(String[] args)`;
const subst = `$1$2$3$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);