re = /(?:\b((?:public|protected|private)\s+)|((?:abstract|static)\s+)|(final\s+)|((?:volatile|synchronized)\s+)|((?:native|strictfp)\s+))+/m
str = ' static public void main(String[] args)'
subst = '$1$2$3$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result