import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\btransition\\s*:\\s*|(?!^)\\G\\s*,?\\s*)([a-z-]+)\\s+(\\d*(?:\\.\\d+)?)s";
final String string = "transition: margin-top 120.22s,\n"
+ " top 20.2s, \n"
+ " left .2s , \n"
+ " right 14s,\n"
+ " margin-right 0s , \n"
+ " margin-left 1.2s\n"
+ " ; should-not-match 1.2s";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}