# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\btransition\s*:\s*|(?!^)\G\s*,?\s*)([a-z-]+)\s+(\d*(?:\.\d+)?)s"
test_str = ("transition: margin-top 120.22s,\n"
" top 20.2s, \n"
" left .2s , \n"
" right 14s,\n"
" margin-right 0s , \n"
" margin-left 1.2s\n"
" ; should-not-match 1.2s")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.