$re = '/(?:\btransition\s*:\s*|(?!^)\G\s*,?\s*)([a-z-]+)\s+(\d*(?:\.\d+)?)s/';
$str = 'transition: margin-top 120.22s,
top 20.2s,
left .2s ,
right 14s,
margin-right 0s ,
margin-left 1.2s
; should-not-match 1.2s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);