using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?\{{2}\h*translateAttr).*(*SKIP)(*F)|=([""'])((?:\\\1|(?!\1).)*)\1";
string input = @"<body>
{{ t ""foo"" }}
{{t ""bar""}}
{{t 'baz'}}
{{ t 'qux' }}
{{ t ""bux {{ var }}"" var=""foo"" }}
{{ button titleTranslation=""button.add_user.title.foo"" }}
{{ button labelTranslation = 'button.add_user.title.bar' }}
{{ translateAttr title=""button. ' add_user.title"" data-disable-with='button.add_user.disabled' }}
{{translateAttr title=""button.! add_user \""quote\"" title"" data-disable-with='button.add_user.disabled'}}
</body>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}