$re = '/^(?!.*?\{{2}\h*translateAttr).*(*SKIP)(*F)|=(["\'])((?:\\\\\1|(?!\1).)*)\1/mi';
$str = '<body>
{{ t "foo" }}
{{t "bar"}}
{{t \'baz\'}}
{{ t \'qux\' }}
{{ t "bux {{ var }}" var="foo" }}
{{ button titleTranslation="button.add_user.title.foo" }}
{{ button labelTranslation = \'button.add_user.title.bar\' }}
{{ translateAttr title="button. \' add_user.title" data-disable-with=\'button.add_user.disabled\' }}
{{translateAttr title="button.! add_user \\"quote\\" title" data-disable-with=\'button.add_user.disabled\'}}
</body>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);