import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[0-9]+ )?(?:(?:[a-z]+[₀-₉]*)+|\\((?:[a-z]+[₀-₉]*)+\\))[₀-₉]*";
final String string = "2 HCl + 12 Na + 3 (Na₃Cl₂)₂₄ → 2 NaCl + H₂";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}