const regex = /((\d{1,3}')*(\d{1,3})\.\d\d)(?=\D+e-mail)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d{1,3}\')*(\\d{1,3})\\.\\d\\d)(?=\\D+e-mail)', 'gm')
const str = `The base item costs 1'245.48, the tax is of 18.45 and the bonus of 250.00, the total price is of 1'013.93. In case of trouble, contact our e-mail. Bank account 784.45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}