use strict;
my $str = 'The base item costs 1\'245.48, the tax is of 18.45 and the bonus of 250.00, the total price is of 1\'013.93. In case of trouble, contact our e-mail. Bank account 784.45';
my $regex = qr/((\d{1,3}')*(\d{1,3})\.\d\d)(?=\D+e-mail)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}