re = /((\d{1,3}')*(\d{1,3})\.\d\d)(?=\D+e-mail)/m
str = 'The base item costs 1\'245.48, the tax is of 18.45 and the bonus of 250.00, the total price is of 1\'013.93. In case of trouble, contact our e-mail. Bank account 784.45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end