package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\/[#@]\s*sourceMappingURL=([^'"]+)\s*$`)
var str = `//# sourceMappingURL=data:application/json;base64,<!--insertbase64encodedsourcemapdatahere-->
i++;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}