$re = '/\/\/[#@]\s*sourceMappingURL=([^\'"]+)\s*$/m';
$str = '//# sourceMappingURL=data:application/json;base64,<!--insertbase64encodedsourcemapdatahere-->
i++;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);