re = /\/\/[#@]\s*sourceMappingURL=([^'"]+)\s*$/m
str = '//# sourceMappingURL=data:application/json;base64,<!--insertbase64encodedsourcemapdatahere-->
i++;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end