#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?<=<p>).*?(?=<\/p>)"
Local $sString = "<p>Hello !</p> <p>I wont select tags! Only text with in</p>" & @CRLF & _
"<p>Hello !</p> <p>I wont select tags! Only text with in</p>" & @CRLF & _
"<p>Hello !</p> <p>I wont select tags! Only text with in</p>" & @CRLF & _
"<p>Hello !</p> <p>I wont select tags! Only text with in</p>"
Local $sSubst = "replace me"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)